linux下安装升级mysql到新版本(5.1-5.7)_Mysql

今天需要把linux服务器上的mysql版本从5.1更新到5.7,那么以下内容作为记录,提供以后安装使用手册

第一步:检查linux的操作系统版本

复制代码 代码如下:

cat /etc/issue

第二步:在mysql官网上下载5.7的版本
http://dev.mysql.com/downloads/file.php?id=451627
第三步:检查linux上以前安装的mysql版本

复制代码 代码如下:

rpm -qa | grep mysql 

第四步:如果出现mysql的一些安装版本,则通过以下命令进行删除

复制代码 代码如下:

rpm -e --nodeps mysql-xxx 

第五步:准备安装新版本的mysql-server

复制代码 代码如下:

 rpm -ivh MySQL-server-xxxx 

第六步:启动mysql server

复制代码 代码如下:

service mysql start 

第七步:安装mysql client

复制代码 代码如下:

rpm -ivh MySQL-client-xxx 

在我安装完成后,发现使用mysql命令怎么都登陆不成功,然后进行了一系列是测试
最后从/usr/share/mysql目录下复制一份my-default.cnf到/etc目录下,r案后重命名为my.cnf

复制代码 代码如下:

cp my-default.cnf /etc 
mv my-default.cnf my.cnf 

然后在my.cnf中的[mysqld]节点下添加以下内容

复制代码 代码如下:

skip-grant-tables 

然后重启mysql

复制代码 代码如下:

service mysql restart 

 然后使用mysql -u -p命令进行登陆
注意:可以使用以下命令进行密码的修改

复制代码 代码如下:

use mysql; 
update user set password=PASSWORD("newword") where user="root"; 
flush privileges; 

希望以上内容对你也有所帮助。

Linux CentOS6环境下MySQL5.1升级至MySQL5.5版本过程

老左今天有在帮朋友的博客搬迁到另外一台VPS主机环境,其环境采用的是LLSMP架构的,原先的服务器采用的是LNMP网站环境,其博客程序是WORDPRESS。告知在导入数据库的时候出现"Unknown collation: 'utf8mb4_unicode_ci'"错误提示,这样的问题应该是WordPress4.2版本之后才有的,以前记得没有出现过这样的问题。
看到WordPress官方社区的文档,有提到MYSQL版本问题导致的,因为默认的LLSMP环境MYSQL是5.1版本的,而LNMP环境中安装的MYSQL是5.5版本的,所以高版本向低版本不兼容,官方的建议是升级MYSQL版本5.5,所以我也采用这个方法。

第一、备份数据库和网站文件

在折腾之前我们还是要备份数据库和网页文件到本地,以免出现问题影响当前的环境以及其他网站的运行。

第二、停止MYSQL运行以及卸载老版本

复制代码 代码如下:

service mysqld stop #暂停MYSQL
yum remove mysql mysql-* #卸载老版本MYSQL

通过上面的命令,我们先停止当前MYSQL的运行,然后再卸载老的MYSQL5.1版本数据库。

第三、检查和卸载残余mysql-libs

复制代码 代码如下:

yum list installed | grep mysql

我们检查是否有残余的mysql-libs,如果有,我们执行下面的命令清除掉。

复制代码 代码如下:

yum remove mysql-libs

执行清除,如果没有不执行也没关系。

第四、升级和安装MYSQL5.5

这里老左参考网上一个快速的方法解决,因为等会要出去办事,在这篇文章就不选择版本安装了,直接采用源包中的5.5默认安装。

复制代码 代码如下:

rpm -Uvh http://dl.fedoraproject.org/pub/epel/6/i386/epel-release-6-8.noarch.rpm
rpm -Uvh http://mirrors.neusoft.edu.cn/epel/6/i386/epel-release-6-8.noarch.rpm
rpm -Uvh http://packages.sw.be/rpmforge-release/rpmforge-release-0.5.2-2.el6.rf.x86_64.rpm
rpm -Uvh http://dl.iuscommunity.org/pub/ius/stable/Redhat/6/x86_64/epel-release-6-5.noarch.rpm
rpm -Uvh http://rpms.famillecollet.com/enterprise/remi-release-6.rpm

先安装一些依赖环境。

复制代码 代码如下:

yum --enablerepo=remi,remi-test info mysql mysql-server

然后再执行安装MYSQL5.5

复制代码 代码如下:

yum --enablerepo=remi,remi-test install mysql mysql-server

执行完成。到目前为止我们可以通过mysql -V检查MYSQL版本已经是5.5,但是现在还不行,根据提示需要进行配置文件,但是不懂为什么老左并没有修改MYSQL的配置文件也可以执行,难道是天意?
第五、启动和检查

复制代码 代码如下:

mysql_upgrade -u root -p

原本根据网络上的方法是需要修改配置文件的,我没修改也可以完成,所以继续执行升级启动的执行,输入当初我们的MYSQL ROOT密码,让过一遍。

完毕之后,我们执行启动MYSQL

复制代码 代码如下:

service mysqld restart

如果能够看到两个绿色的OK,那就一切没有问题。

总结,这样我们再去导入数据库就不会出现编码问题。看到有文档提到可以直接在导出MYSQL数据库的时候选择版本的,后面老左试试,因为升级MYSQL存在很多不安和麻烦,万一出错就麻烦了。

时间: 2016-03-24
Tags: 升级MySQL

linux下安装升级mysql到新版本(5.1-5.7)_Mysql的相关文章

我也很纳闷,网上linux下安装appache,mysql之类的软件,都有好长一段代码来配置修改文件

问题描述 我也很纳闷,网上linux下安装appache,mysql之类的软件,都有好长一段代码来配置修改文件该问题来自CSDNDocker技术交流群(303806405),由版主xinshubiao整理.

Linux下安装管理mysql数据库

一.卸载掉原有mysql 我们通过工具SecureCRT 5.1连接到linux服务器,要用root管理员用户,如果是普通用户登录的话,可以通过su  -  root切换为root管理员用户. 我下载的Linux系统集成了mysql数据库在里面,我们可以通过命令来查看我们的操作系统上是否已经安装了mysql数据库: rpm -qa | grep mysql 有的话,我们就通过命令卸载掉: rpm -e --nodeps mysql 删除完以后我们再用 rpm -qa | grep mysql 命

mysql-在Linux下安装的Mysql的配置文件在哪里?

问题描述 在Linux下安装的Mysql的配置文件在哪里? 最近学习Hadoop,到了Hive看视频上用的是已经安好的Mysql,于是我就自己安一个. 我用apt-get命令安装了Mysql-server和Mysql-Client,但是不知道安装好后在哪里修改配置文件,而且安装完后其它的后续步骤都不会操作,还是使用mysql命令时出现Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (

Linux下安装Python3和django并配置mysql作为django默认服务器方法_Linux

我的操作系统为centos6.5 1  首先选择django要使用什么数据库.django1.10默认数据库为sqlite3,本人想使用mysql数据库,但为了测试方便顺便要安装一下sqlite开发包. yum install mysql mysql-devel #为了测试方便,我们需要安装sqlite-devel包 yum install sqlite-devel 2  接下来需要安装Python了,因为Python3已经成为主流,所以接下来我们要安装Python3,到官网去下载Python3

Linux下安装MySQL出现“ls: /var/lib/mysql/*.pid: 没有那个文件或目录”

环境 RedHat Linux 9 + VWWare 8.0 + SSH 3.2.9 + Putty 0.62 + MySQL 3.2 + MySQL 5.5 问题 Linux下安装MySQL出现如下错误: warning: MySQL-server-5.5.28-1.linux2.6.i386.rpm: V3 DSA signature: NOKEY, key ID 5072e1f5 Preparing... ##########################################

《PHP和MySQL Web开发从新手到高手(第5版)》一一1.4 在Linux下安装

1.4 在Linux下安装 PHP和MySQL Web开发从新手到高手(第5版)如今,大多数选用Linux操作系统的人都是技术高手,他们肯定知道如何安装像Apache.PHP和MySQL这样的软件.实际上,他们可能已经对于该如何安装有很强的认识,那我再过多地描述就没有什么意义了. 如果你是我所提到的这类读者,请继续用你习惯的安装方式去安装Apache.PHP和MySQL最新的版本,使用任何的包管理程序或内建的过程来安装.本书中没有什么内容是如此高深的,以至于配置这些包的任何细小差别都会有所影响.

Linux下安装MySql+Apache2+PHP5.3.1教程

Linux下安装MySql+Apache2+PHP5.3.1教程 请先下载下面三个安装必要的软件   01-04php-5.3.1.tar.gz.html">php-5.3.1.tar.gz安装包下载 01-04httpd-2.2.14.tar.gz 安装包下载 01-04mysql-5.1.42-linux-i686-glibc23.tar.gz.html">mysql-5.1.42-linux-i686-glibc2   一.安装apache2-------------

linux下安装mysql的问题解决

今天试了下在Linux下安装mysql,我只选了server和client两个组件,没有装其他的组件. 安装包的下载可以参见 http://www.mysql.com/downloads/ server端的安装: [root@oel2 install_mysql]# rpm -ivh MySQL-server-advanced-5.6.14-1.rhel5.i386.rpm Preparing...                #################################

在Linux下安装显卡驱动程序

程序     { 相信大多数人在安装Linux时遇到的第一个难题,就是Linux不认你的显卡.而显卡安装不正确或胡乱选一个驱动程序安上则难以进入X Window.即使勉强进去了,因为分辨率太低,桌面上的文字和图片都放大了好几倍,仍无法使用.我的Linux是Red Hat,显卡是Trident Blade 3D,属于Linux不认识之列.于我是四处找资料,经过一段时间的摸索,终于成功地安装了显卡驱动.现在我就把经验写出来,好让大家都能顺利进入X Window,领略Linux的风采.    一.下载