OSPF次优路由选择的探讨

拓扑为工大瑞普ccnp实验lab17,描述如下:

R1(S1/1)--R2(S1/0),cost=10;R1(S1/2)-framerelay-R4(S1/2),cost=2

R2(S1/1)--R3(S1/0),cost=2,R2(F0/0)--R4(F0/0),cost=2

R3(S1/1)--R4(S1/0),cost=5

R1的F0/0口连接网络192.168.1.0/24,cost=1

R1#show run

interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0

!

interface Serial1/1
description DCE,OSPF area 0,connected to R2's S1/0,ip 172.16.255.2/30
ip address 172.16.255.1 255.255.255.252
ip ospf cost 10
clock rate 9600
!
interface Serial1/2
description FrameRelay,OSPF area 0,connected to R4's S1/2,ip 172.16.255.14/30
ip address 172.16.255.13 255.255.255.252
encapsulation frame-relay
ip ospf network broadcast
ip ospf cost 2
!

router ospf 100
router-id 1.1.1.1
network 172.16.255.0 0.0.0.3 area 0
network 172.16.255.12 0.0.0.3 area 0
network 192.168.1.0 0.0.0.255 area 2
!

////////////////////

R2#show run

interface FastEthernet0/0
description OSPF area 1,connected to Network 172.16.255.16/30
ip address 172.16.255.17 255.255.255.252
ip ospf cost 2
!
interface Serial1/0
description DTE,OSPF area 0,connected to R1's S1/1,ip 172.16.255.1/30
ip address 172.16.255.2 255.255.255.252
ip ospf cost 10
!
interface Serial1/1
description DCE,OSPF area 1,connected to R3's S1/0,ip 172.16.255.6/30
ip address 172.16.255.5 255.255.255.252
ip ospf cost 2
clock rate 9600
!

router ospf 100
router-id 2.2.2.2
network 172.16.255.0 0.0.0.3 area 0
network 172.16.255.4 0.0.0.3 area 1
network 172.16.255.16 0.0.0.3 area 1
!

////////////////////

R3#show run

interface Serial1/0
description DTE,OSPF area 1,connected to R2's S1/1,ip 172.16.255.5/30
ip address 172.16.255.6 255.255.255.252
ip ospf cost 2
!
interface Serial1/1
description DCE,OSPF area 1,connected to R4's S1/0,ip 172.16.255.10/30
ip address 172.16.255.9 255.255.255.252
ip ospf cost 5
clock rate 9600
!

router ospf 100
router-id 3.3.3.3
network 172.16.255.4 0.0.0.3 area 1
network 172.16.255.8 0.0.0.3 area 1

!

////////////////////

R4#show run

interface FastEthernet0/0
description OSPF area 1,connected to Network 172.16.255.16/30
ip address 172.16.255.18 255.255.255.252
ip ospf cost 2
!
interface Serial1/0
description DTE,OSPF area 1,connected to R3's S1/1,ip 172.16.255.9/30
ip address 172.16.255.10 255.255.255.252
ip ospf cost 5
!

interface Serial1/2
description FrameRelay,OSPF area 0,connected to R1's S1/2,ip 172.16.255.13/30
ip address 172.16.255.14 255.255.255.252
encapsulation frame-relay
ip ospf network broadcast
ip ospf cost 2
!

router ospf 100
router-id 4.4.4.4
network 172.16.255.8 0.0.0.3 area 1
network 172.16.255.12 0.0.0.3 area 0
network 172.16.255.16 0.0.0.3 area 1

!

R3#traceroute 192.168.1.1

更多精彩内容:http://www.bianceng.cnhttp://www.bianceng.cn/Network/lyjs/

 1 172.16.255.5 24 msec 68 msec 12 msec
 2 172.16.255.1 20 msec *  20 msec

R3#show ip route
    172.16.0.0/30 is subnetted, 5 subnets
O IA    172.16.255.0 [110/12] via 172.16.255.5, 00:00:07, Serial1/0
C       172.16.255.4 is directly connected, Serial1/0
C       172.16.255.8 is directly connected, Serial1/1
O IA    172.16.255.12 [110/6] via 172.16.255.5, 00:00:07, Serial1/0
O       172.16.255.16 [110/4] via 172.16.255.5, 00:00:07, Serial1/0
O IA 192.168.1.0/24 [110/7] via 172.16.255.5, 00:00:07, Serial1/0

从R3到达192.168.1.0/24,最少的cost为R3-R2-R4-R1=7,可实际路由为R3-R2-R1=13。为何出现这样的情况?

首先查看R3的ospf database:

R3#show ip ospf data

               Router Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum Link count
2.2.2.2         2.2.2.2         673         0x80000005 0x003C97 3
3.3.3.3         3.3.3.3         615         0x80000003 0x005569 4
4.4.4.4         4.4.4.4         628         0x80000005 0x00951E 3

               Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum
172.16.255.17   2.2.2.2         673         0x80000002 0x002C22

时间: 2016-11-28

OSPF次优路由选择的探讨的相关文章

ospf的注意事项_服务器

1. ospf是不能使用secondary ip建立邻居关系的 2. 只有secondary ip和primary ip在同一area内的时候,才能被宣告出去 3. 一个area内可以有多个DR,但一个广播域内只能有一个DR 4. ospf在p2p的链路上是不支持unnumbered ip的 5. distribute-list可以在inbound方向上阻止路由插入路由表, 但不能阻止lsa进入lsdb. 也就是为什么outbound distribute-list在链路状态路由协议上不起作用,

《OSPF和IS-IS详解》一1.5 ARPANET内的路由选择

1.5 ARPANET内的路由选择 OSPF和IS-IS详解 1983年,在ARPANET内,人们展开了把网络协议从NCP切换成TCP/IP的割接工作.当时,有两拨研究人员同时都在使用ARPANET,分别来自军方和非军方(大学或企业).就人数而论,第二拨人要多得多,有很多大学生也在学着掌握或使用计算机网络,这反过来又对整个计算机行业产生了影响.此外,还有很多人出于非研究性的目的而使用计算机网络,比如,玩网络游戏.由于使用网络的用户群日渐庞大,美国国防部开始考虑网络的安全性问题,并将军用节点都迁移

《OSPF和IS-IS详解》一6.1 OSPF数据库同步

6.1 OSPF数据库同步 OSPF和IS-IS详解 读至本章,读者想必知道,OSPF协议是一种结构性很强的路由协议.既然读者都清楚OSPF数据库同步的可靠性和精确性是如此重要,那么也就不会对用来管理OSPF数据库同步过程的状态机(名为邻居状态机)的复杂程度感到惊讶了.简而言之,在数据库同步过程中,邻居状态机会驱动(OSPF路由器)采取以下"行动". 1.当相邻的两台路由器决定彼此建立邻接关系时,会进行分工:一台起"主导"作用,另外一台会进行"配合&quo

《OSPF和IS-IS详解》一第6章 链路状态数据库同步6.1 OSPF数据库同步

第6章 链路状态数据库同步 OSPF和IS-IS详解 有一句话作者此前曾反复提及,现在再说一遍:链路状态路由协议的"精髓"在于,隶属同一区域的每台路由器都会根据存储在一个公共拓扑数据库里的信息,执行本机路由计算.因此,在同一区域内,每台路由器所存储的拓扑数据库的内容必须完全一样.路由器之间相互同步链路状态数据库的目的正是为此.在OSPF或IS-IS网络中,路由器只要上线运行,就必须与邻居路由器进行数据库同步,以确保各自所持数据库的内容完全相同.若路由器刚接入点到点链路,便会与链路对端的

《OSPF网络设计解决方案(第2版)》一2.4 OSPF路由分层

2.4 OSPF路由分层 OSPF网络设计解决方案(第2版) OSPF协议最为重要的特性之一便是它支持分层的路由结构.当你思考OSPF如何在这种分层结构上运行时,请牢记下面的两个特点. 为了使得OSPF能够正常地运行,必须存在或创建分层结构. 应当优先关注如何划分明确的拓扑,而不是地址编址. 自治系统(AS)是指在同一管理域内的一组共享相同路由策略的区域的集合.自治系统使用唯一的编号进行标识,该编号可以是公共的或私有的,这取决于网络的需求.自治系统号必须由特定的组织或机构来分配,如北美的Inte

《OSPF网络设计解决方案(第2版)》一2.3 SPF概述

2.3 SPF概述 OSPF网络设计解决方案(第2版) OSPF是一个链路状态路由协议,此类协议在一些技术文档及文献中也被称为基于SPF的协议,或者是分布式数据库协议.本节讨论链路状态算法的发展,以及该算法对OSPF协议产生的影响. 什么是链路状态协议? OSPF是一个链路状态协议.那什么是链路状态呢?你可以将链路看作是路由器上的一个接口,而链路的状态也就是对该接口的描述.这种描述包括了接口的IP地址和掩码,以及接口所连接网络的类型和状态.OSPF将网络中所有路由器的链路状态信息汇总于链路状态数

《OSPF网络设计解决方案(第2版)》一2.8 案例分析:OSPF网络的构建和收敛

2.8 案例分析:OSPF网络的构建和收敛 OSPF网络设计解决方案(第2版) 之前的两个案例分析回顾了链路状态数据库以及它的建立过程.本节将通过新的案例分析来讨论本章之前已经介绍过的一些概念,除此以外,本节还将讨论如何构建一个简单的OSPF网络以及网络的收敛. 假设 MatrixNet 是一家专注于影视特效的高科技动画公司,并想要在其核心网络内实施 OSPF.该公司的核心网络内拥有三台通过以太网相互连接的路由器,如图2-19所示. 在本节案例中,你需要在3台Cisco路由器上配置OSPF.但必

《OSPF网络设计解决方案(第2版)》一2.1 什么是路由协议

2.1 什么是路由协议 OSPF网络设计解决方案(第2版) 路由协议的产生需要经历一系列的过程:通过RFC(征求评议,Request for Comments)流程,并最终成为正式化的协议.该流程包括对一项提议技术征求公开的成文评议,并努力对该技术进行完善和标准化.由RFC 2328所定义的OSPF便是路由协议标准化的例子. 注意 如需查阅具体的RFC文档内容,你可以登录下面的网站,并通过RFC编号或关键字进行检索:http://www.rfc-editor.org/rfc.html. 学习 O

《OSPF网络设计解决方案(第2版)》一1.6 IP编址

1.6 IP编址 OSPF网络设计解决方案(第2版) 本节讨论IP编址的方法.基本子网划分.可变长子网掩码(VLSM)及无类域间路由(CIDR). 在设计及配置都较为合理的网络环境中,主机和服务器之间的通信可视为透明的.这是因为,每台使用TCP/IP协议簇的设备都拥有长度为32比特的唯一IP地址.设备读取数据包的目的IP地址,并基于该信息做出正确的路由决策.如果设备是主机或服务器,那么它们将借助默认网关进行数据包转发:如果是一台路由器,那么则参照路由表将数据包转发至目的地.只要使用了正确的IP编